Archive for the ‘VSTS’ Category

Upgrading VSTS Beta 3 to RC and Cruise Control

February 16, 2006

Well I was going to do a little introductory post for my first ever post but I figured I may as well put something usefull out there and then do an intro later (if I get time that is….).

Last night I upgraded our install of MS Team Foundation Server from the Beta 3 to the RC, making sure to follow all the instructions carefully. This went really smoothly and everyone seems to be back underway this morning (whew). The only things I came across where:

1) There are two KB packages mentioned in the install doc – these are found on the RC disk if you are wondering where they are.

2) Read http://blogs.msdn.com/vstsue/articles/500334.aspx as stated in the install doc – One thing it mentions is the backup of the encryption key for the reporting services database. I didnt see this anywhere else so if it goes bad it might pay to do this as well.

3) Read Jonesie’s blog as well (http://jonesie.net.nz/TFSRCUpgradeFun.aspx given to me by /\ndrew at http://andrewpeters.wordpress.com/). He mentions hitting the registaration service. I’m not sure if this was fixed with the patched installer but I did it anyway and the upgrade worked so why not a 🙂 Also, the re-install of the team explorer client is another thing to note.

4) Make sure you also do the install under a domain account – not just logged in as the admin on the box. I think with the beta 3 it told you to but you could get away with it … can’t remember now but that’s something to watch out for – If you forget then just login and restart the install 😉

Apart from that it all just seemed to work. The cool things I did find out though were:

1) You can delete TFS projects using TFSDeleteProject.exe found under C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\ . We found that people wanted to play with the first install of the TFS box but once the root node was in there we couldnt really get rid of it (didnt know how to completelly delete it). I’m not sure if we just didnt spot a gui option from vs but this little guy works when run from the server or a client machine 🙂 The annoying thing is that if the creation of the project fails the root node can end up in there but then the delete won’t seem to work! Arrhhh – I’m not sure if you can try the creation again with the same name or if it just kind of gets stuck …. something I’ll have to look into

2) If you are using cruise control with the vsts plugin (http://vstsplugins.sourceforge.net/) then this will need to be recompiled. Grab the source and do a rebuild – it will fall over but (as a dirty hack to get our box running again) I commented out the line:

teamFoundationServer = TeamFoundationServerFactory.GetServer(this.Server, this.Credentials);

that it fails on and replaced it with the line:

teamFoundationServer = TeamFoundationServerFactory.GetServer(this.Server);

I spent like less than 5 minutes on it but I patched the dlls up onto the server and cruisecontrol is up and running again (copied all the ccnet ones and the vsts plugin dll as well). This is probibly not the best but I just wanted to get it working again – Hopefully someone might find it usefull until the actual vsts plugin dll gets recompiled on the official download site 🙂 (I’ll try and post the dll’s up soon if someone just wants to download them – Hopefully it will work just as well for you as it did for me – Just having some upload issues at the mo)

Advertisements